Archive FAQ > Technical Questions

What browsers is the Archive compatible with?

The Archive is currently optimized for Firefox 15.0 and above. We also support Internet Explorer 9 and above, Chrome 20 and above, and Safari 5 and above. We also try to ensure the Archive works at a basic level in the default android and iOS browsers. We're doing our best to support a range of browsers and mobile devices and welcome your feedback on any bugs you encounter, but we do have to prioritize fixes for those which are most frequently used to access the Archive.

What else do I need to use the Archive?

Some features of the Archive will not work without javascript enabled. You should still be able to browse, but some other features may not function correctly. If you're having difficulties, you should check that javascript is enabled.